Rabu, 08 Mei 2013

MPLS BACKBONE

MPLS pada dasarnya terdiri dari 3 jenis router :
  1. Router P (Provider)
    • Terdapat dalam MPLS domain, P router terhubung dengan router-router lain yang dimiliki service provider
    • Pada jaringan MPLS yang tidak terlalu besar terkadang tidak terdapat P router didalamnya untuk menghemat biaya. 
     2.  Router PE (Provider Edge)
    • Merupakan router yang terhubung langsung dengan router customer dan juga sekaligus dengan router provider
    • Menjembatani antara network berbasis IP dengan network berbasis MPLS
    • Memberikan pelabelan pada paket IP yang masuk kedalam MPLS Domain
    • Melepas pelabelan pada paket yang akan keluar dari MPLS Domain
    • PE router ini sifatnya harus ada pada setiap  jaringan MPLS
     3.  Router CE (Customer Edge)
    • Merupakan router yang terdapat di sisi customer
    • Pada router CE ini tidak terdapat konfigurasi MPLS apapun
    • Konfigurasi routing biasa, bisa static atau dynamic seperti OSPF / EIGRP
Karena pada jaringan MPLS Backbone hanya ada router P dan router PE, maka model jaringan MPLS yang sederhana seperti di bawah :




Tahapan konfigurasi jaringan MPLS :

  1. Konfigurasikan IP address pada semua interface router 
  2. Mengaktifkan Dynamic Routing
  3. Mengaktifkan BGP
  4. Mengaktifkan MPLS
1. Konfigurasi IP address

PE1(config)#int lo0
PE1(config-if)#ip add 10.10.10.1 255.255.255.255
PE1(config-if)#int s0/0
PE1(config-if)#ip add 192.168.10.1 255.255.255.252
PE1(config-if)#description ### link to p router ###
PE1(config-if)#no shut

P(config)#int lo0
P(config-if)#ip add 10.10.10.10 255.255.255.255
P(config-if)#int s0/0
P(config-if)#ip add 192.168.10.2 255.255.255.252
P(config-if)#description ### link to PE1 router ###
P(config-if)#no shut
P(config-if)#int s0/1
P(config-if)#ip add 192.168.20.1 255.255.255.252
P(config-if)#description ### link to pe2 router ###
P(config-if)#no shut

PE2(config)#int lo0
PE2(config-if)#ip add 10.10.10.2 255.255.255.255
PE2(config-if)#no shut
PE2(config-if)#int s0/0
PE2(config-if)#ip add 192.168.20.2 255.255.255.252
PE2(config-if)#description ### link to P router ###
PE2(config-if)#no shut

Setelah semua ip address di konfigurasikan lakukan ping ke masing-masing IP Point-to-Point nya.

PE1#ping 192.168.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/36/64 ms

P#ping 192.168.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/28/56 ms
P#ping 192.168.20.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/48/84 ms

PE2#ping 192.168.20.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/36/56 ms

2. Mengaktifkan dynamic routing (OSPF)
agar semua router dalam MPLS Domain dapat saling berkomunikasi satu sama lain, maka diperlukan Dynamic Routing IGP seperti misalnya OSPF..

PE1(config)#router ospf 1
PE1(config-router)#net 192.168.10.1 0.0.0.0 area 0
PE1(config-router)#net 10.10.10.1 0.0.0.0 area 0

P(config)#router ospf 1
P(config-router)#net 192.168.10.2 0.0.0.0 area 0
P(config-router)#net 192.168.20.1 0.0.0.0 area 0
P(config-router)#net 10.10.10.10 0.0.0.0 area 0

PE2(config)#router ospf 1
PE2(config-router)#net 192.168.20.2 0.0.0.0 area 0
PE2(config-router)#net 10.10.10.2 0.0.0.0 area 0

Cek routing tabelnya...

PE1#sh ip route
Gateway of last resort is not set

     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial0/0
     192.168.20.0/30 is subnetted, 1 subnets
O       192.168.20.0 [110/128] via 192.168.10.2, 00:03:16, Serial0/0
     10.0.0.0/32 is subnetted, 3 subnets
O       10.10.10.10 [110/65] via 192.168.10.2, 00:03:06, Serial0/0
O       10.10.10.2 [110/129] via 192.168.10.2, 00:01:31, Serial0/0
C       10.10.10.1 is directly connected, Loopback0

P#show ip route
Gateway of last resort is not set

     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial0/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial0/1
     10.0.0.0/32 is subnetted, 3 subnets
C       10.10.10.10 is directly connected, Loopback0
O       10.10.10.2 [110/65] via 192.168.20.2, 00:02:12, Serial0/1
O       10.10.10.1 [110/65] via 192.168.10.1, 00:04:18, Serial0/0

PE2#show ip route
Gateway of last resort is not set

     192.168.10.0/30 is subnetted, 1 subnets
O       192.168.10.0 [110/128] via 192.168.20.1, 00:03:32, Serial0/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial0/0
     10.0.0.0/32 is subnetted, 3 subnets
O       10.10.10.10 [110/65] via 192.168.20.1, 00:03:32, Serial0/0
C       10.10.10.2 is directly connected, Loopback0
O       10.10.10.1 [110/129] via 192.168.20.1, 00:03:32, Serial0/0

Kemudian lakukan tes ping

PE1#ping 10.10.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
PE1#ping 10.10.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/61/88 ms
PE1#ping 10.10.10.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

3. MENGAKTIFKAN BGP
BGP perlu di konfigurasikan karena nanti kita membutuhkan MP-BGP, untuk melewatkan informasi routing, vpn dan vrf. Konfigurasi BGP hanya dikonfigurasikan pada masing-masing PE router saja.

PE1(config)#router bgp 65000
PE1(config-router)#neighbor 10.10.10.2 remote-as 65000
PE1(config-router)#neighbor 10.10.10.2 update-source loopback0

PE2(config)#router bgp 65000
PE2(config-router)#neighbor 10.10.10.1 remote-as 65000
PE2(config-router)#neighbor 10.10.10.1 update-source loopback0

    Selanjutnya verivikasi BGP peeringnya

PE1#sh ip bgp summary
BGP router identifier 10.10.10.1, local AS number 65000
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.10.10.2      4 65000       5       5        1    0    0 00:01:29        0

PE2#sh ip bgp summary
BGP router identifier 10.10.10.2, local AS number 65000
BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.10.10.1      4 65000       5       5        1    0    0 00:01:47        0

4. MENGAKTIFKAN MPLS
MPLS dikonfigurasikan pada semua router baik P dan PE router

PE1(config)#mpls ip
PE1(config)#interface s0/0
PE1(config-if)#mpls ip

P(config)#mpls ip
P(config)#interface s0/0
P(config-if)#mpls ip
P(config)#interface s0/1
P(config-if)#mpls ip

PE2(config)#mpls ip
PE2(config)#interface s0/0
PE2(config-if)#mpls ip

Setelah dikonfigurasikan, untuk pengecekan apakah MPLS sudah aktif dan berjalan dengan baik, gunakan perintah "show mpls forwarding-table

PE1#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     192.168.20.0/30   0          Se0/0      point2point
17     Pop tag     10.10.10.10/32    0          Se0/0      point2point
18     16          10.10.10.2/32     0          Se0/0      point2point

P#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     10.10.10.2/32     2461       Se0/1      point2point
17     Pop tag     10.10.10.1/32     1493       Se0/0      point2point

PE2#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     192.168.10.0/30   0          Se0/0      point2point
17     Pop tag     10.10.10.10/32    0          Se0/0      point2point
18     17          10.10.10.1/32     0          Se0/0      point2point

0 komentar:

Posting Komentar